Excel – Berechnung nur bei vorhandenem Wert

Gesten habe ich die gezeigt, wie eine kumulierte Summe von einem vorgegebenen Wert abgezogen werden kann. Das funktioniert prima, wenn schon alle Werte in Spalte A eingetragen sind, sieht aber irritierend aus, wenn noch Werte fehlen.

 

29.05.2018_0003

 

Obwohl  in den Zeilen 12 bis 14 noch gar keine Entnahmen verzeichnet sind, wird der neue Endbetrag errechnet. Schöner und übersichtlicher wäre es, wenn nur dann in Spalte B ein neuer Betrag steht, wenn in A auch etwas eingetragen ist.

 

Dafür verwenden Sie eine WENN-Funktion, die zuerst einmal erfragt, ob in A in der gleichen Zeile ein Wert steht:

WENN(A2<>””; …

 

Wenn A2 nicht leer ist – die beiden Zeichen <> bedeuten “nicht” und die zwei Anführungszeichen “” stehen für “leer”.

 

Daran schließt sich die Formel von gestern an: Wenn A2 nicht leer ist, dann berechne die Differenz:

=WENN(A2<>””;$A$1-SUMME($A$2:A2);…

 

Fehlt noch, was ansonsten berechnet werden soll – nichts. Also wieder zwei Anführungszeichen:

=WENN(A2<>””;$A$1-SUMME($A$2:A2);””)

 

Fertig und nach unten  ausfüllen.

Hinterlasse jetzt einen Kommentar

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*