Excel – SVERWEIS findet nichts wegen Leerschritten

Der SVERWEIS soll nach der Personalnummer suchen, findet sie aber nicht, weil die Suchspalte leider nicht sehr gepflegt ist.

 

22.03.2018_0006

 

Der SVERWEIS in F2 lautet

=SVERWEIS(E2;A2:C5;2;FALSCH)

 

Obwohl das Suchkriterium B-104 in der Matrix vorkommt, liefert Excel einen Fehler. Einige Personalnummern werden gefunden, andere nicht. Die Kontrolle zeigt, dass immer wieder Nummern mit Leerschritten eingegeben wurden. Eine schnelle Korrektur ist bei Hunderten von Nummern nicht möglich.  Da die Liste ständig neu aus einer anderen Quelle gezogen wird, wäre es auch unpraktisch, eine Hilfsspalte einzufügen. Es ist also eine  Lösung gefragt, die ausschließlich im SVERWEIS eingreift.

 

Und diese Lösung sieht so aus:

=SVERWEIS(E2;GLÄTTEN(A2:C5);2;FALSCH)

 

22.03.2018_0007

 

Die Funktion muss mit STRG+SHIFT+ENTER abgeschlossen werden. In meinem Screenshot ist das erkennbar an den geschweiften Klammern um die Funktion. Bei jeder Änderung an der Formel muss immer wieder mit STRG+SHIFT+ENTER abgeschlossen werden.

 

Die innenliegende Funktion GLÄTTEN sorgt dafür, dass Leerschritte vor und hinter den Einträge abgeschnitten werden.

Hinterlasse jetzt einen Kommentar

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*