Excel–Wer kommt in der anderen Liste nicht vor? (3-3)

Schlussendlich möchte ich die farbigen Hervorhebungen ohne Hilfsspalten erreichen. Meine Firmennamen stehen in den Spalten A und B:

23.02.2018_0006

Gestern und Vorgestern habe ich mit einer Hilfsspalte gearbeitet und jeweils das Vorkommen links und rechts separat erfasst – wer 2017 eine 1 hatte, war nur 2017 dabei, aber nicht 2018; wer umgekehrt in 2018 eine 1 hatte, ist neu und war 2017 noch nicht an Board. Darum gab es zwei ZÄHLENWENN, die addiert wurden.

Jetzt stehen die Listen direkt nebeneinander und der Bereich ist vereinigt: Von A2 bis B72 soll gezählt werden. Zuerst soll gezählt werden, wie oft der Name aus A2, dann wie oft der aus B2 vorkommt. In einer bedingten Formatierung geht das mit einer Formel.

Markieren Sie den gesamten Bereich von A2 bis B72 und rufen Sie die bedingte Formatierung auf.

  • Wählen Sie “Formel zur Ermittlung der zu formatierenden Zellen verwenden”
  • Tragen Sie als Formel ein:
    =ZÄHLENWENN($A$2:$B$72;A2)=123.02.2018_0007
  • Achten Sie auf die absoluten Bezüge für den Bereich A2:B72 und den absoluten relativen Bezug für A2!
  • Wählen Sie “Formatieren” und dann “Ausfüllen”, bestimmen Sie eine Füllfarbe und beenden Sie alle Dialoge mit OK.

FazitÜber drei Tage ist die Auswertung erst gewachsen und dann immer “spartanischer” geworden: zuerst zwei Formeln, dann zwei Formeln plus zwei bedingte Formatierungen, zum Schluss eine einzige bedingte Formatierung mit einer Formel. Das ist sinnvoll, um sich langsam an eine Lösung heranzutasten.

  • Beginnen Sie mit Hilfsspalten, rechnen Sie erst einmal und kontrollieren Sie, ob die Ergebnisse korrekt sind
  • Mit diesen Ergebnissen bauen Sie die bedingte Formatierung auf – und kontrollieren wieder, ob das so stimmt
  • Versuchen Sie dann, die Berechnung in die bedingte Formatierung zu übernehmen
  • Fassen Sie eventuell Formeln zusammen, wenn das möglich ist (so wie ich es im letzten Schritt gemacht habe)

Die fertige Tabelle  gibt es hier.

1 Kommentar

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*