Excel–Wer kommt in der anderen Liste nicht vor? (1-3)

Zwei Listen sollen verglichen werden: welche Firma war nur im letzten Jahr auf der Firmenfeier, welche in beiden Jahren und welche nur in diesem Jahr? Der Übersichtlichkeit halber habe ich erst einmal beide Listen nebeneinander gestellt.

23.02.2018_0000

Ab Zeile 9 wird es unterschiedlich: Büro Mayer war nur 2017 dabei, fehlt in 2018; genauso ist Büroausstattung Ilmtal nur 2017 dabei. Weiter unten tauchen dann Firmennamen nur in 2018 auf, waren in 2017 noch nicht dabei. Die Listen sind auch unterschiedlich lang: 71 in 2017, 72 in 2018.

Wie kann man vorgehen? Eine Möglichkeit ist das Zählen aller Einträge. Wie oft taucht der Name aus A2 in den Zellen A2 bis B100 auf? Wie oft der Name aus B2? Und so fort. Wer nur einmal auftaucht, war nur in dem einen oder dem anderen Jahr dabei.

23.02.2018_0001

Die Formel in B2 lautet:

=ZÄHLENWENN($A$2:$A$99;A2)+ZÄHLENWENN($C$2:$C$99;A2)

Zuerst wird der Bereich A2 bis A99 durchsucht nach dem Namen aus A2; dabei wird ermittelt, wie oft diese Firma in Spalte A bei der Feier 2017 vorkommt. Dann wird der Bereich von C2 bis C99 durchsucht – ebenfalls nach dem Namen aus A2; dabei wird ermittelt, wie oft der Name in Spalte C bei der Feier 2018 vorkommt. Beide werden addiert. Wer an beiden Feiern dabei war bekommt 1+1=2; wer nur in einem der Jahre dabei war 1+0 oder 0+1=1.

Achten Sie darauf, die Bereiche A2:A99 und C2:C99 absolut zu setzen, den Suchbegriff in A2 aber relativ zu lassen!

Füllen Sie die Formel nach unten aus. Kopieren Sie die Formel nach D2 und kontrollieren Sie, dass jetzt nach dem Suchbegriff aus C2 gesucht wird.

Wer selber üben will, kann sich die Excel-Tabelle hier herunterladen.

Morgen zeige ich Ihnen, wie Sie alle Namen, die nur einmal vorkommen, farbig markieren – zuerst mit der Hilfsspalte, dann ohne.

1 Trackback / Pingback

  1. Excel–Wer fehlt? – Pia Bork

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*