Excel–Datum als Überschrift in formatierter Tabelle

Gestern habe ich gezeigt, wie man mit SVERWEIS, VERGLEICH und TEXT nach einer Spaltenüberschrift suchen kann, die aus einer Ziffer oder einer Jahreszahl besteht – auch in einer formatierten Tabelle. Heute ergänze ich das Beispiel um die Suche nach einem Datum.

Die Tabelle hat dieses Mal als Spaltenüberschriften ein Datum im Format TT.MM.JJJJ. Die formatierte Tabelle ist mit “Messpunkte_Dez” benannt. In B14 soll zum angegebenen Messpunkt und dem Datum das Ergebnis gezeigt werden.

09.12.2017_0000

In einer nicht-formatierten Tabelle geht der SVERWEIS, der selber nach einer Spaltennummer sucht, ganz einfach so:

=SVERWEIS(B13;A1:F11;VERGLEICH(A14;A1:F1;0);FALSCH)

Der VERGLEICH sucht nach dem Datum aus A14 in der Überschriftenzeile A1:F1 und liefert den Spaltenindex 2 zurück, mit dem SVERWEIS dann den Messwert findet.

In der formatierten Tabelle muss das Datum aus A14 erst wieder in einen Text mit dem Format eines Datums verwandelt werden: TEXT(A14;”TT.MM.JJJJ”)

Der VERGLEICH sucht also so: VERGLEICH(TEXT(A14;”TT.MM.JJJJ”);A1:F1;0)

Und alles im SVERWEIS sieht dann so aus:

=SVERWEIS(B13;Messpunkte_Dez;VERGLEICH(TEXT(A14;”TT.MM.JJJJ”);A1:F1;0);FALSCH)

Die Funktion TEXT muss immer das Datumsformat erzeugen, das in der Überschrift (scheinbar) angezeigt wird. Wenn in der Überschrift A1:F1 steht 12/2017, dann müssen Sie in das Format MM/JJJJ umwandeln.

Um überhaupt in die Überschriftenzeile einer formatierten Tabelle ein Datumsformat wie 12/2017 eingeben zu können, müssen Sie zuerst die Zellen formatieren und dann die Zahl eintragen! Andersherum geht es nur, wenn Sie sich nicht in einer formatierten Tabelle befinden!

lemon_vehicle_1600_clr_19443Es werden auch keine bestehenden Datumsformate in andere Schreibweisen umgewandelt – aus Dez 2017 wird nicht 12/2017, wenn Sie die Überschriftenzellen umformatieren. Sie müssen a) zuerst mit MM/JJJJ formatieren und b) die Datumswerte neu als 12/2017 eintragen.

Für all diese kleinen Ärgernisse vergebe ich für formatierte Tabellen eine goldene Zitrone!

Hinterlasse jetzt einen Kommentar

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*