Excel–Zahlen als Überschrift in formatierter Tabelle

In formatierten Tabellen werden Zahlen in Überschriften als Texte gespeichert – davon sind auch Jahreszahlen betroffen. Normalerweise kann uns das egal sein, aber wenn man mit den Überschriften etwas “machen” will, kann das ein Ärgernis sein.

Ein Beispiel war der Blogbeitrag vom 08.12.2017, in dem ich gezeigt habe, wie man mit SVERWEIS und VERGLEICH die Spaltenzahl herausfindet. Das funktionierte in diesem Beispiel nur, weil ich bewusst keine formatierte Tabelle verwendet habe.

Formate ich meine Liste aber als mit “Formatierte Tabelle”, kann ich mit der Funktion VERGLEICH keine Spaltenzahl mehr ermitteln. Genauso ging es mir in dieser Tabelle:

  • Überschriften in Zeile 1 sind Ziffern für die vier Messreihen
  • Die Formel =SVERWEIS(H2;A1:E15;VERGLEICH(H3;A1:E1;0);FALSCH) liefert in einer nicht formatierten das Ergebnis 1061 für den Messpunkt B14 in der Messreihe 1.

08.12.2017_0000

Die gleiche Tabelle als formatierte Tabelle mit der gleichen Formel liefert #NV

08.12.2017_0001

Man sieht schon deutlich, dass meine vier Messreihen nicht mehr als Ziffern rechtsbündig, sondern wie Texte linksbündig stehen. Mein erster Versuch, die Messreihe in Zelle H3 ebenfalls als Text zu formatieren, scheiterte. Erst die Teamarbeit brachte des Rätsels Lösung – dickes Danke an Dietmar Gieringer für den Tipp!

Der VERGLEICH muss das Textformat liefern.
=SVERWEIS(H2;Messreihen[#Alle];VERGLEICH(TEXT(H3;”#”);Messreihen[#Kopfzeilen];0);FALSCH)

Die Funktion TEXT verwende ich in erster Linie, um Datum und Text zu koppeln, aber dennoch die Datumsschreibweise beizubehalten. Ein Beispiel findet sich im Blog vom 18.03.2014. Hier dient TEXT dazu, den Suchbegriff aus H3 in einen Text mit einem einfachen Zahlenformat zu verwandeln. Das einfache Zahlenformat wird durch “#” symbolisiert.

Auch in meinem Beispiel vom 08.12.2017 wäre diese Schreibweise möglich gewesen, um nach der Jahreszahl zu suchen. Die Formel muss so aussehen:
=SVERWEIS(B2;Umsatz[#Alle];VERGLEICH(TEXT(B1;”#”);E1:O1;0);FALSCH)

08.12.2017_0002

Obwohl meine Jahreszahl vier Ziffern hat, reicht es aus, das Zahlenformat mit “#” anzugeben.

Morgen zeige ich, wie man nach einem Datum aus der Überschrift suchen kann.

2 Kommentare

  1. Hallo Pia,

    =SVERWEIS(H2;Messreihen[#Alle];VERGLEICH(H3&””;Messreihen[#Kopfzeilen];0);FALSCH)

    funktioniert auch!

    Gruß

    Christian Neuberger

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*