Excel – SVERWEIS sucht Spaltennummer selber

Der SVERWEIS erfordert, dass Sie angeben, aus welcher Spalte eine Information geholt werden soll. In diesem Beispiel soll zur Kunden-Nummer aus Zelle B2 und dem Jahr aus B1 der Umsatz ausgegeben werden:

 

04.12.2017_ 0000

 

Die Matrix oder Referenztabelle steht der Übersichtlichkeit auf dem gleichen Blatt – sie kann aber selbstverständlich auf einem separaten Blatt stehen! In meinem Beispiel ist die Matrix in den Spalten F bis O keine formatierte Tabelle.

Normalerweise müsste der SVERWEIS so aussehen:

=SVERWEIS(B2;E1:O20;8;FALSCH)

Dabei steht die “8” für die achte Spalte – also hier das Jahr 2013. Und diese “8” muss ich abzählen. Bei wenigen Spalten ist das ja ok, aber bei zehn, zwanzig oder mehr Spalten wird das … naja. Mühsam ist noch nett.

 

Diese 8 will ich automatisch ermitteln. Dafür gibt es die Funktion VERGLEICH. Diese Formel ermittelt die Position des Begriffes “2013” in der Überschriftszeile:

=VERGLEICH(B1;E1:O1;0) ermittelt diese Ziffer “8”

Dabei ist B1 die Zelle mit dem zu suchenden Begriff; E1:O1 ist die Überschriftszeile – hier soll der Begriff gesucht werden; “0” (Null) steht für “Genaue Übereinstimmung”.

 

Diese Funktion wird an der Stelle eingebaut, an der im SVERWEIS die Spaltennummer eingegeben werden muss:

=SVERWEIS(B2;$E$2:$O$20;VERGLEICH(B1;E1:O1;0);FALSCH)

 

Damit bin ich flexibel. Die Eingabe der Jahresziffer in Zelle B1 führt automatisch dazu, dass die entsprechende Spaltennummer aus der Überschrift herausgesucht wird.

 

04.12.2017_ 0001

1 Trackback / Pingback

  1. Excel–Zahlen als Überschrift in formatierter Tabelle – Pia Bork

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*