Excel – Bestanden oder nicht bestanden

 

Fünf Klausuren sind geschrieben, in jeder musste eine Mindestpunktzahl erreicht werden. Schlussendlich hat bestanden, wer immer mehr als die Mindestpunktzahl hatte oder nur in einer einzigen Klausur die Mindestpunktzahl nicht erreichte.

 

10.10.2017_ 0001

 

Wer in zwei Klausuren weniger als das Minimum geschafft hat, hat nicht bestanden. Karla zum Beispiel hat in Klausur 4 nur 3 Punkte, aber sonst immer das Minimum geschafft: bestanden. Susi hat in Klausur 3 und 5 knapp die Mindestpunktzahl erreicht: bestanden. Miguel hat in einer Klausur Null Punkte und in einer war er knapp unter der Mindestpunktzahl: nicht bestanden.

 

Die Hervorhebung der Mindestpunktzahl in gelb geschieht mit der bedingten Formatierung. Markieren Sie B3 bis F8 und wählen “Start | Bedingte Formatierung | Neue Regel | Formel zur Ermittlung der zu formatierenden Zellen verwenden”. Tragen Sie als Formel ein

=B3<B$1

 

10.10.2017_ 0002

 

Achten Sie auf den relativen Bezug für B1 (ohne Dollarzeichen) und den gemischten Bezug für B1 (Dollarzeichen vor der Zeile, die damit fixiert wird, aber nicht vor der Spalte, die also relativ bleibt).

Wählen Sie mit “Formatieren” eine Füllfarbe und bestätigen Sie alles mit OK.

 

Die Berechnung für die Spalte G “Gesamt” haben wir mit einer Kombination aus WENN, UND und XODER gemacht.

Zuerst haben wir eine Bedingung erstellt, die “bestanden” ausgibt, wenn jemand in allen Klausuren mehr als die Mindestpunktzahl erreicht hat.

UND(B3>=B$1;C3>=C$1;D3>=D$1;E3>=E$1;F3>=F$1)

Kommt hier WAHR heraus, hat der Kandidat auf jeden Fall bestanden.

 

Dann haben wir überlegt, wie wir herausfinden können, ob jemand höchstens einmal gepatzt hat. Es eignet sich XODER

XODER(B3<B$1;C3<C$1;D3<D$1;E3<E$1;F3<F$1)

Kommt hier WAHR heraus, hat der Kandidat ebenfalls noch bestanden. Zur Erinnerung: XODER erlaubt nur, dass eine einzige Bedingung WAHR sein darf; sind zwei oder mehr Bedingungen WAHR, ist das Gesamtergebnis wiederum FALSCH. Sie können das am 10.10.2017 hier im Blog nochmal nachlesen.

 

Wenn also diese Bedingungen WAHR sind, gibt es ein “Bestanden”; in allen anderen Fällen ein “Nicht bestanden”.

=WENN(UND(B3>=B$1;C3>=C$1;D3>=D$1;E3>=E$1;F3>=F$1); “bestanden”;
WENN(XODER(B3<B$1;C3<C$1;D3<D$1;E3<E$1;F3<F$1); “bestanden”;
“nicht bestanden”))

 

Wir haben  zwei WENN ineinander verschachtelt, die ich der Deutlichkeit halbe hier untereinander schreibe – in Excel ist das alles in einer Zeile.

Sie können  die Datei hier herunterladen.

Hinterlasse jetzt einen Kommentar

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*