Excel–ODER oder XODER?

In den logischen Funktionen gibt es immer schon die Funktion ODER. Sie wird meistens mit WENN verwendet, um herausfinden, ob Bedingung A oder B oder C erfüllt ist.

In Spalte F wird ermittelt, ob der Schüler ein Stipendium bekommt. Die Regel ist:

  • entweder hat der Schüler Klausur 1 mehr als 95 Punkte
  • oder in Klausur 2 mehr als 95 Punkte
  • oder in Klausur 3 mehr als 90 Punkte
  • oder er/sie hat einen Zusatzkurs besucht

06.10.2017_0002

Die Formel in F2 lautet:

=WENN(ODER(B2>95;C2>95;D2>90;E2=”ja”);”ja”;”nein”)

Würde ich keine WENN verwenden, sondern nur ODER, erhalte ich WAHR oder FALSCH:

=ODER(B2>95;C2>95;D2>90;E2=”ja”)

06.10.2017_0003

ODER prüft also, ob eine der angegebenen Bedingungen WAHR ist. Dabei können auch mehrere Bedingungen WAHR sein. Klaus hat die Voraussetzungen in drei Bereichen erfüllt: Klausur 1 und 3 sind über dem Sollwert und einen Zusatzkurs hat er auch.

In diesem Beispiel “versagt” ODER allerdings aus unserer Sicht:

06.10.2017_0004

Geprüft wird in Spalte C, ob die Kreuzchen für “nimmt teil” und “nimmt nicht teil” korrekt gesetzt wurden. Es kann nur ein Entweder-Oder sein, niemand kann sowohl teilnehmen als auch nicht-teilnehmen. Die Formel in C2 lautet:

=ODER(A2=”x”;B2=”x”)

ODER prüft allerdings, ob eine von beiden oder auch beide Bedingungen WAHR sind. So steht in C4 ein WAHR – aber das nicht richtig! Korrekt darf nur ein Kreuzchen gesetzt sein, nicht beide.

Dafür gibt es XODER. Dabei wird ein echtes “Entweder – Oder” geprüft. Es darf nur A2 oder B2 ein Kreuzchen haben, nicht beide.

06.10.2017_0005

In C2 steht jetzt:

=XODER(A2=”x”;B2=”x”)

Und hier wird richtig geurteilt: Zeile 4 ist falsch ausgefüllt – hier gibt es zwei Kreuzchen.

1 Trackback / Pingback

  1. Excel – Bestanden oder nicht bestanden – Pia Bork

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*