Excel – Mendelsche Gesetze mit bedingter Formatierung

Erinnern Sie sich an die Herrn Mendel und die Erbsen? Gregor Mendel hat verschiedene Erbsen gekreuzt, um herauszufinden, wie sich Merkmale vererben. Unter anderem wurden Erbsen mit gelben und solche mit grünen Samen gekreuzt. Dabei kam es zu einem Ergebnis, das den Laien verblüfft: Grün mit Gelb ergibt nur grüne Nachfahren; die grünen Nachfahren unter sich erzeugen aber zu 25 % gelbe Nachkommen. Und das kann man sehr schön in Excel darstellen.

In Zeilen 1 und 2 sind die Eltern dargestellt: die grünen Erbsensamen tragen in sich das Merkmal DD (D steht für “Dominant grün”), die gelben Erbsensamen tragen das Merkmal rr (r steht für “rezessiv gelb” – rezessiv bedeutet “nicht in Erscheinung tretend). Die Bezeichnungen sind nicht biologisch! Da müsste ich für das dominante Grün ein großes G und für das rezessive Gelb ein kleines g verwenden – aber Excel kann bei den notwendigen Berechnungen Groß- und Kleinschreibung nicht unterscheiden. Darum halte ich mich nicht an die Konventionen der Biologen.

 

xl_0477

Die Eltern geben von ihren beiden Merkmalen (DD oder rr) jeweils eines an die Nachkommen weiter. In den Zeilen 4 bis 7 steht das Ergebnis: alle Nachkommen bekommen ein D und ein r, es kommt also für alle Dr heraus. Um das zu berechnen steht in Zelle D6 die Formel: =D$5&$C6. Diese Formel kann zuerst nach rechts, dann nach unten ausgefüllt werden.

Alle Nachkommen mit einem großen D sind auf jeden Fall grün, nur Nachkommen  mit zwei kleinen r sind gelb. Damit kann eine bedingte Formatierung erstellt werden.

  • Markieren Sie D6 bis E7
  • Wählen Sie “Start | Bedingte Formatierung | Regeln zum Hervorheben von Zellen”
  • Wählen Sie “Textinhalt”
  • Geben Sie ein “rr” und weisen Sie eine gelbe Füllfarbe zu

Im Regelassistent (Bedingte Formatierung | Regel verwalten | Regel bearbeiten) zeigt diese Regel später so an:

xl_0478

Weisen Sie für den gleichen Bereich die gleiche Regel zu mit dem Textinhalt “D” – die Füllung ist jetzt “grün”.

Erstellen Sie genau das gleiche in den Zeilen 10 bis 13. Kreuze ich zwei Nachkommen aus der ersten Generation wiederum miteinander, habe ich jeweils ein D und r zu verteilen. Die Darstellung ist also wie oben zu sehen: ein D und r oben und ein D und r links. Wieder wird mit einer Formel kombiniert =D$11&$C12; nach rechts und unten ausfüllen. Ebenso wird mit der gleichen bedingten Formatierung formatiert.

Wie ist das Verhältnis? In der ersten Generation sind 100 % grün; in der zweiten Generation sind 75 % grün und 25 % gelb. Die beiden r kombinieren sich bei einem Viertel der Nachkommen zu zwei rr und erzeugen gelbe Samen – obwohl beide Eltern grüne Samen haben!

xl_0479

Die Formel in Zelle D18 lautet: =ZÄHLENWENN(D14:E15;”rr”)/ANZAHL2($D$14:$E$15)

In Zelle E18 steht: =ZÄHLENWENN(D14:E15;”*d*”)/ANZAHL2($D$14:$E$15)

 

Das Verhältnis bleibt jetzt immer gleich. Ich habe mal alle vier Nachkommen aus Zeile 14 und 15 kombiniert:

xl_0480

Und auch hier sind es 25 % gelbe und 75 % grüne Samen.

Natürlich ist das alles ein bisschen komplizierter, aber um die Mendelschen Gesetze einmal zum Anfassen zu haben, ist es ein feines Beispiel. Wer mehr über Mendel und die Mendelschen Gesetze lesen will, sei auf die Wikipedia verwiesen. Für Laien verständliche Biologie-Bücher zu diesem Thema sind rar gesät, am ehesten sind noch Einführungen in die Botanik geeignet.

Hinterlasse jetzt einen Kommentar

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*