Excel 2016–WENNS

Mit Excel 2016 gibt es ein paar neue Funktionen – WENNS ist eine davon. Sie haben sicherlich erraten, worum es dabei geht: WENN mit mehreren Bedingungen.

12.02.2017_0000

In der Tabelle rechts sollen unterschiedliche Skonti für den Kundentyp A, B oder C ausgegeben werden:

  • A bekommt 3 %
  • B bekommt 2 %
  • C bekommt 1 %

Herkömmlich würde das mit einer verschachtelten WENN-Funktion gemacht:
=WENN(B2=”A”;3%;WENN(B2=”B”;2%;1%))

Alternativ bietet sich hier auch ein SVERWEIS an.

Seit Excel 2016 geht das mit WENNS. Der generelle Aufbau von WENNS ist:

=WENNS(Wahrheitstest1;Wert wenn wahr 1;Wahrheitstest2;Wert wenn wahr 2;Wahrheitstest3;Wert wenn wahr 3;….)

127 Wahrheitstest lassen sich so nacheinander durchführen.

In meinem Beispiel lautet die Formel für C2:

=WENNS(A2=”A”;3%;A2=”B”;2%;A2=”C”;1%)

WENNS kennt – anders als WENN – keinen “Sonst-Wert”. Mit der verschachtelten WENN-Funktion oben gehe ich so vor: WENN B2 gleich A ist, dann 3%; WENN B2 gleich B ist, dann 2 %; in allen anderen Fällen (sonst) 1%.

Anders ist WENNS: ich gehe nur eine Bedingung nach der anderen durch – es gibt kein “Sonst”. Was aber tun, wenn ich das brauche? In der gleichen Tabelle sollen die Skonti nicht nach Kunden-Typ, sondern nach Umsatz gestaffelt werden.

 >12.000 (größer 12.000) 3 %
>10.000 und <=12.000 (größer 10.000 und kleiner oder gleich 12.000) 2 %
<=10.000 (kleiner oder gleich 10.000) 1 %

Es gibt zwei mögliche Schreibweisen für diesen Fall:

=WENNS(B2>12000;3%;B2>10000;2%;B2<=10000;1%)

oder

=WENNS(B2>12000;3%;B2>10000;2%;WAHR;1%)

In der ersten Formel gehe ich wieder alle drei Bedingungen explizit durch; in der zweiten Formel schreibe ich zum Schluss “WAHR” und weise diesem letzten Wert 1 % zu. Dieses WAHR steht für alle übrigen Bedingungen. Egal, was sonst noch kommt – es ist auf jeden Fall als “WAHR” zu werten.

Frage an die SVERWEIS-Könner: Warum kann ich in diesem Beispiel nicht mit dem SVERWEIS arbeiten?

Denkpause.

 

Noch mehr Denkpause.

12.02.2017_0002Wie ist der SVERWEIS aufgebaut?

Die Matrix steht F1:G4.
Der SVERWEIS rechnet grundsätzlich “ab 0”, “ab 10.000”, “ab 12.000”. So wird der Umsatz von 10.000 mit einem Prozentsatz von 2 % ausgegeben – nach meiner Vorgabe darf es aber nur 1 % sein. Ich will alles, was kleiner oder gleich 10.000 ist mit 1 % belohnen. Genauso bei 12.000 – es soll nur 2 % geben, aber der SVERWEIS ermittelt 3 %.

 

 

Eine sehr schöne Zusammenstellung zu WENNS gibt es auf dem Blog von Hildegard Hügemann.

Hinterlasse jetzt einen Kommentar

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*