Excel – Nullwerte im Diagramm

Wenn in einer Messreihe Werte fehlen,  entstehen Lücken im Diagramm. Hier werden Werte als Zahlen eingetragen und an einigen Stellen wurde nichts eingetragen – die Zellen sind leer.

 

27.11.2016_ 0000

 

Für tatsächlich leere Zellen können Sie bestimmen, wie die Darstellung ist. Markieren Sie das Diagramm, wählen Sie “Diagrammtools | Daten auswählen: Ausgeblendete und leere Zellen”. Standard ist “Lücken”. Sie können wählen “Null” – dann wird die Linie nach unten auf die Achse gezogen – oder “Datenpunkt mit einer Linie verbinden”, dann werden die Daten verbunden.

27.11.2016_ 0004

 

Wenn aber die Fehlstellen durch eine Funktion =WENN(B2>18;B2;””) entsteht, behandelt Excel die leeren Zellen wie eine Null und wandert mit der Linie nach unten auf die Achse:

27.11.2016_ 0002

 

Anders reagiert Excel, wenn in der Funktion anstelle von “” die leere Zelle mit NV() entsteht: =WENN(B2>18;B2;NV())

27.11.2016_ 0003

 

Jetzt wird zwischen den bekannten Punkten davor und danach interpoliert – es wird der Zwischenwert errechnet.

Hinterlasse jetzt einen Kommentar

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*