Excel – Diagramm mit flexibler Datenbeschriftung

Ein Linien-Diagramm mit Beschriftung der Datenpunkte ist unflexibel. Die Beschriftungen sitzen alle an der gleichen Stelle: immer oberhalb oder unterhalb der Datenpunkte. Schöner wäre es, wenn die Beschriftung einmal oben  und einmal unten wären:

 

23.11.2016_ 0001

 

Damit das funktioniert, brauche ich neben den Daten für die Linie zwei weitere Reihen für die Position der Beschriftungen.

  • Label oben
    Oberhalb des Datenpunktes steht die Beschriftung, wenn der Wert größer ist als der des Vormonats
  • Label unten
    Unterhalb des Datenpunktes steht die Beschriftung, wenn der Wert kleiner ist als der des Vormonats

 

In B3 übernehme ich mit =B2 den ersten Wert aus dem Januar. Somit wird der Wert 1.500 oberhalb des Datenpunktes stehen.

Ab C2 vergleiche ich den aktuellen Wert mit dem Vormonat. Ist der Wert größer als aus dem Vormonat, soll der Wert angezeigt werden.

=WENN(C2>B2;C2;NV())

Falls das nicht stimmt, soll die Stelle im Diagramm ausgespart werden. Das passiert mit “NV()”. Würde ich eine Null oder einen  Leerschritt ausgeben lassen, würde die Beschriftung auf den Nullpunkt gesetzt.

In C4 vergleiche ich ebenfalls mit dem Vormonat, ist er kleiner, soll der Wert angezeigt werden. Auch hier kommt wieder “NV()” zum Einsatz.

=WENN(C2<B2;C2;NV())

 

23.11.2016_ 0002

 

In Zeile 3 werden vier Werte angezeigt, die jeweils größer als der Vormonat sind: Januar, Februar, April und Juni müssen also oberhalb beschriftet werden. März und Mai bleiben frei.

In Zeile 4 werden zwei Werte angezeigt, die kleiner als der Vormonat sind: März und Mai. Der Januar wurde schon in Zeile 3 belegt und Februar, April und Juni bleiben frei.

So wird das Diagramm aufgebaut:

  • Markieren Sie A1 bis G2 und erstellen Sie ein Liniendiagramm

    23.11.2016_ 0003

  • Klicken Sie auf “Diagrammtools | Entwurf | Daten auswählen” und dann auf “Hinzufügen”
  • Markieren Sie als Rubrikenname die Zelle A3 und als Reihenwerte die Zellen B3 bis G3; bestätigen Sie mit OK.

    23.11.2016_ 0004

  • Klicken Sie erneut auf “Hinzufügen”
  • Markieren Sie als Rubrikenname die Zelle A4 und als Reihenwerte die Zellen B4 bis G4; bestätigen Sie mit OK
  • Bestätigen Sie auch den nächsten Dialog mit OK.
  • Klicken Sie auf “Diagrammtools | Entwurf | Diagrammtyp ändern”
  • Wählen Sie “Verbund”
  • Stellen Sie ein
    Ausgaben: Linie
    Label oben: Punkt (XY)
    Label unten: Punkt (XY)

    23.11.2016_ 0005

  • Bestätigen Sie mit OK

Markieren Sie jetzt die Datenpunkte für die Datenreihe “Label oben” und klicken Sie auf das Pluszeichen rechts oben neben dem Diagramm. Wählen Sie “Datenbeschriftung: Über”.

23.11.2016_ 0006

 

Markieren Sie jetzt die Datenreihe “Label unten” und weisen Sie ebenfalls die Datenbeschriftung zu, wählen Sie aber “Unter”.

Sie können die Datenpunkte noch so formatieren, dass sie nicht zu sehen sind. Klicken Sie doppelt auf einen Punkt der Reihe “Label oben”. Klicken Sie im rechten Aufgabenbereich auf “Füllung und Linien”, dann auf “Markierung”.

23.11.2016_ 0007

Stellen Sie ein “Keine Füllung” und “Keine Linie”. Genauso machen Sie es für “Label unten”.

Zum Schluss entfernen Sie die senkrechte Achse. Sie können Sie einfach markieren und mit ENTF löschen. Ebenso markiere ich die Gitternetzlinien und lösche Sie.

Hinterlasse jetzt einen Kommentar

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*