Excel – Werte suchen

In einer Tabelle wird erfasst, welcher Mitarbeiter Urlaub hat. In der letzten Zeile werden alle U gezählt mit ZÄHLENWENN.

23.10.2016_0002

Die Formel in B9:

=ZÄHLENWENN(B4:B8;”U”)

In einem anderen Bereich (im Beispiel oben H4 bis I8) stehen die Datumsangaben untereinander und es sollen die Summen für Urlaubstage ermittelt werden. Es muss also die Zeile 1 des grau hinterlegten Bereiches von B bis F durchlaufen werden, um das Datum zu finden und dann muss die Zahl aus der Zeile 7 ausgegeben werden.

Die Formel in I4:

=WVERWEIS($H4;$B$3:$F$9;7;FALSCH)

23.10.2016_0003

H4 ist die Zelle mit dem zu suchenden Datum; die Spaltenfixierung ist für dieses Beispiel nicht zwingend notwendig.

B3:F9 ist der Bereich, der durchsucht werden soll; er muss fixiert werden, damit die Formel nach unten kopiert werden kann.

7 ist die Zeilennummer des zu durchsuchenden Bereiches

FALSCH ist als Argument notwendig, wenn ein Datum nicht gefunden wird. Bei einem nicht vorhandenen Datum muss eine Fehlermeldung ausgegeben werden, es darf nicht das nächste Ergebnis verwendet werden.

Sie sehen, die Schreibweise ist sehr ähnlich zum SVERWEIS. Der SVERWEIS durchsucht die erste Spalte einer Matrix senkrecht, der WVERWEIS die erste Zeile waagerecht.

Hinterlasse jetzt einen Kommentar

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*