Quiz Lösung – Excel Anzahl ermitteln

Am Freitag, den 21.10.2016, habe ich die Aufgabe gestellt aus einer Liste die Anzahl für eine Abteilung sowie für drei Teams zu ermitteln.

13.10.2016_0005In der Excel-Tabelle werden die Mitarbeiter mit Abteilung und der Zugehörigkeit zu einem Team aufgelistet. Sie benötigen

  • die Anzahl der Mitarbeiter für die Abteilung “Produktion” in B2
  • die Anzahl der Mitarbeiter aufgeschlüsselt nach Lager/Versand, Montage/Service und Fertigung in D2, D3 und D4.

Das Problem ist, dass Blatt und Arbeitsmappe geschützt sind, so dass weder Sortieren noch Filtern noch Teilergebnisse oder eine Pivot-Tabelle möglich sind.

Formel in B2      =ZÄHLENWENN(Stammdaten[Abteilung];A2)

D2                    =ZÄHLENWENN(Stammdaten[Team];C2)

D3                    =ZÄHLENWENN(Stammdaten[Team];C3)

D4                   =ZÄHLENWENN(Stammdaten[Team];C4&”*”)

Die Bezeichnung “Stammdaten[Abteilung]” bzw. “Stammdaten[Team]” ist bedingt durch die formatierte Tabelle.

Die drei Teams Fertigung A, Fertigung B und Fertigung C werden gemeinsam gezählt durch C4&”*”. In C4 steht der allgemeine Begriff “Fertigung”. Mit &”*” wird diesem Begriff ein Sternchen angehängt, der Platzhalter für “beliebige Zeichenkette”. Gefunden wird also alles, was mit “Fertigung” beginnt und einen beliebigen Zusatz hat.

Hinterlasse jetzt einen Kommentar

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*