Outlook – Kalendertermine in Excel berechnen

Aus dem Outlook-Kalender soll eine Übersicht aller Fahrten in einem Zeitraum als Tabelle erstellt werden. Die Reisezeiten sollen berechnet und addiert werden.

Zuerst muss der Kalender als Tabelle dargestellt werden, die Termine werden sortiert und eventuell auch gefiltert:

  • Ansicht | Ansicht ändern: Liste
  • Ansichtseinstellungen
    • Sortieren: Sortieren nach Beginn
    • Filtern: z. B. nach Kategorien oder nach Worten im Betreff
  • Alles mit OK bestätigen

Markieren Sie alle Termine, die Sie kopieren wollen  und drücken Sie STRG+C oder klicken Sie in die markierten Zeilen mit der rechten Maustaste und wählen Sie “Kopieren”. In Excel fügen Sie die Zellen zuerst einmal mit STRG+V ein.

Alle überflüssigen Spalten löschen Sie in Excel. Datum und Uhrzeit stehen jeweils in einer einzigen Spalte, das muss aufgelöst werden. Sie brauchen dazu sowohl hinter der Spalte Beginn als auch hinter Ende eine leere Spalte:

06.10.2016_ 0001

Markieren Sie die Spalte “Beginn” und wählen Sie “Daten | Text in Spalten”. Aktivieren Sie “Getrennt”, klicken Sie auf “Weiter” und wählen Sie im nächsten Schritt “Leerschritt”. Klicken Sie auf “Weiter”.

06.10.2016_ 0002

Im nächsten Schritt ist die erste Spalte mit den abgekürzten Tagesnamen markiert – sie wird nicht gebraucht und muss nicht übernommen werden. Klicken Sie “Spalte nicht importieren (überspringen)” an und bestätigen Sie alles mit “Fertigstellen”.

06.10.2016_ 0003

 

Machen Sie genau das Gleiche für die Spalte “Ende”, aber wählen Sie für die ersten beiden Spalten “Spalte nicht importieren”. Wir brauchen weder die Tagesnamen noch das Datum, nur die Uhrzeit. Jetzt sieht die Tabelle so aus:

06.10.2016_ 0004

 

In D wird jetzt die Dauer berechnet. Die Formel für Zelle D2 lautet im einfachsten Fall:

=C2-B2

Das gilt nur dann, wenn immer alles am gleichen Tag beginnt und endet. Eine Zugfahrt, die um 20:50 am ersten Tag beginnt und um 00:10 am zweiten Tag endet, würde aber falsch berechnet. Dann muss die  Formel etwas komplizierter sein:

=WENN(C2>B2;C2-B2;C2+1-B2)

Um die Uhrzeiten in dezimaler Schreibweise zu bekommen  (also 2,5 statt 02:30) muss es so sein:

=WENN(C2>B2;(C2-B2)*24;(C2+1-B2)*24)

Genaueres zu Berechnung von Uhrzeiten finden Sie im Lexikon.

Ich habe zum Schluss die Uhrzeiten noch auf eine Nachkommastelle gerundet:

=RUNDEN(WENN(C2>B2;(C2-B2)*24;(C2+1-B2)*24);1)

Und das ist das Ergebnis:

06.10.2016_ 0005

Hinterlasse jetzt einen Kommentar

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*