Excel – Kalenderwochen-Übersicht

Eine Terminübersicht soll anhand von Kalenderwochen erstellt werden. Angegeben wird ein Start- und ein Enddatum. Aus beiden Datumsangaben wird jeweils die Kalenderwoche errechnet. In einer Tabelle wird dann eine Grafik erstellt:

 

23-05-_2016_16-31-12

 

Zuerst einmal die Berechnung der Kalenderwochen  in den Spalte C und D:

=KALENDERWOCHE($A2;2) bzw. =KALENDERWOCHE($C2;2)

=KALENDERWOCHE($A2;21) bzw. =KALENDERWOCHE($C2;21)

In Zeile 1 habe ich die Kalenderwochen-Nummern von 1 bis 52 eingetragen – also nichts Berechnetes.

Ab E2 wird ein x in die Zelle geschrieben, wenn die Start-KW kleiner oder gleich der KW in Zeile 1 und die Ende-KW größer oder gleich der KW in Zeile 1.

 

20.04.2016_ 0004

 

Die Formel lautet:

=WENN(UND($B2<=E$1;$D2>=E$1);”x”;””)

Füllen Sie das nach rechts und unten aus. Jetzt werden “x” in die Zellen geschrieben. Da ich keine X sehen will, sondern blaue Füllungen (ohne X) setze ich noch eine bedingte Formatierung auf den Bereich von E2 bis BD14. Die bedingte Formatierung sieht so aus:

  • Regeltyp: Nur Zellen formatieren, die enthalten
  • Zellwert gleich x
  • Formatieren: Füllung blau und Schriftfarbe das gleiche Blau

 

20.04.2016_ 0005

 

Die Datei können  Sie sich hier herunterladen.

3 Kommentare

  1. Ein Fehlerteufel hat sich eingeschlichen, danke René für den Hinweis. Die Formel ist korrigiert im Blog zu sehen – statt des Argumentes “2” muss es “21” sein. Ich habe bewusst nicht die neue ISOKALENDERWOCHE verwendet, weil die in den älteren Excel-Versionen nicht funktioniert.

  2. Hoi Pia
    Vielen Dank! Das ist eine schöne und einfache Möglichkeit für eine optische Darstellung, wenn MS-Project “overdosed” ist.
    Kann es sein, dass der Link zur Datei ins Leere führt? Bei mir jedenfalls.
    Liebe Grüsse
    Gino

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*