Excel – SVERWEIS Schritt für Schritt

look_who_has_an_idea_300_clr_7993

Haben Sie die Lösung gefunden?

 

 

 

 

 

Aufgabe 1:

Der Postversand von Paketen und Päckchen kostet bis 2 kg 4,90 Euro, bis 10 kg 6,90 Euro, bis 20 kg 11,90 Euro, bis 31,5 kg 13,90 Euro – darüberhinaus muss man fragen.
Sie sollen ein Formular aufbauen, in das nur das Gewicht eingetragen wird und Excel gibt den Preis aus. Das Gewicht wird in Zelle B1 eingetragen, die Referenztabelle ist eine formatierte Tabelle und heißt “Portotabelle”.

  1. Wird der exakte oder der ungefähre Wert gesucht? Gesucht ist der ungefähre Wert – jeweils bis zu einer Höchstgrenze
  2. Müssen Sie WAHR oder FALSCH als Argument einbauen?Deswegen muss das Argument WAHR verwendet werden.
  3. Muss die Referenztabelle sortiert sein oder ist das nicht notwendig?Und die Referenztabelle muss aufsteigend sortiert sein.

07.10.2013_ 0004

Der SVERWEIS für B2 sieht so aus:
=SVERWEIS(B1;Portotabelle;2;WAHR)

Aufgabe 2:

Eine Firma gibt unterschiedliche Rabatte für Ihre Kunden. Kunden der Kategorie A1 bekommen 10 %, Kunden der Kategorie A2 erhalten 8 %; für die Kategorie B1 gibt es 4 % und für B2 3 %; Neukunden sind in der Kategorie C und erhalten 1,5 %.
In einem Rechnungsformular wird in C10 die Kundenkategorie eingetragen, darunter soll der Prozentwert ermittelt werden. Die Referenztabelle ist wieder eine formatierte Tabelle und heißt “Rabatt”.

  1. Wird der exakte oder der ungefähre Wert gesucht?Es wird ein exakter Wert gesucht.
  2. Müssen Sie WAHR oder FALSCH als Argument einbauen?Darum brauchen wir das Argument FALSCH
  3. Muss die Referenztabelle sortiert sein oder ist das nicht notwendig?Und es ist nicht unbedingt notwendig, dass die Referenztabelle sortiert ist.

07.10.2013_ 0005

Der SVERWEIS für C11 sieht so aus:
=SVERWEIS(C10;Rabatt;2;FALSCH)

highlighter_marker_text_11965
Achtung!
Es gibt eine kleine Falle: Der SVERWEIS übernimmt nicht das Format aus der Spalte I. Sie müssen also C11 als Prozent formatieren – und dann noch zwei Nachkommstellen hinzufügen lassen. Sonst erhalten Sie statt 1,5 % aufgerundete 2 %.

Mit C11 wird dann in E7 weitergerechnet: =E6*C11

Sie können auch auf C11 verzichten und in E7 direkt schreiben:
=E6*SVERWEIS(C10;Rabatt;2;FALSCH)

Nachtrag zur ersten Aufgabe:
Wie würden Sie vorgehen, wenn es mehrere Preisstaffeln gibt – so wie es ja bei der Post auch ist? Gewicht ist nur das eine Kriterium, dann wird noch unterschieden in Inland, Europa und Welt.

07.10.2013_ 0006
Ich gebe das Gewicht ein und für die Zone eine Ziffer, wenn das Paket außerhalb Deutschlands geliefert werden soll. Für Deutschland bleibt Zelle B2 leer.

Lösung? Morgen!

Hinterlasse jetzt einen Kommentar

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*