Excel – SVERWEIS Schritt für Schritt

Bislang haben wir unsere Beispiele ohne Fehler ausprobiert. In der Realität kommt es aber oft vor, dass ID-Nummern nicht lückenlos sind – so wie hier: zwischen A102 und A104 sowie zwischen A105 und A107 sowie A107 und A109 klafft eine Lücke.

08.10.2013_ 0002

Werden im Eingabebereich Artikel-Nummern eingegeben, die nicht existieren, gibt es Fehlermeldungen:

08.10.2013_ 0003

Das kann man so lassen und als “Nicht vorhanden” interpretieren. Schöner wäre es natürlich, wenn in der Artikelbezeichnung zum Beispiel “Falsche Artikelnummer” steht und der Preis leergelassen würde. Das können Sie mit WENNFEHLER abfangen.

=WENNFEHLER(Berechnung;Wert, wenn ein Fehler in “Berechnung” auftritt)

=WENNFEHLER(SVERWEIS($B2;$G$2:$I$9;2;FALSCH);”falsche Artikel-Nr.”)

bzw. für den Preis in Spalte D

=WENNFEHLER(SVERWEIS($B2;$G$2:$I$9;3;FALSCH);””)

und für den Gesamtpreis in Spalte E

=WENNFEHLER(A2*D2;””)

Dann sieht die Eingabemaske so aus:

08.10.2013_ 0004

Oder mit einer bedingten Formatierung etwas auffälliger:

08.10.2013_ 0005

Die Bedingung für C2 lautet:

  • Nur Zellen formatieren, die enthalten
  • Zellwert – gleich – “falsche Artikel-Nr.”
  • Formatiert mit roter Füllung
  • mit dem Format-Übertragen-Pinsel nach unten übertragen

08.10.2013_ 0006

Die Bedingung für B2 lautet:

  • Formel zur Ermittlung der zu formatierenden Zellen verwenden
  • =$C2=”falsche Artikel-Nr.”
  • Formatiert mit roter Füllung
  • Ebenfalls mit dem Format-Übertragen-Pinsel nach unten übertragen

08.10.2013_ 0007

Hinterlasse jetzt einen Kommentar

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*