Excel – Stundensätze zuordnen

Stundensätze sollen automatisch je nach gewählter Staffelung zugeordnet werden. Dazu werden auf dem Blatt “Raten” die Preise geführt.  Das Tabellenblatt ^”Raten” ist so aufgebaut:

30.03.2016_ 0002

Daraus soll auf einem anderen Blatt der jeweilige Preis ermittelt werden. In Zelle B1 kann über das Auswahlfeld die Rate gewählt werden, in A2 ebenfalls über ein Auswahlfeld die Hierarchie:

30.03.2016_ 000330.03.2016_ 0004

B1 und A2 sind mit einer Datenüberprüfung formatiert. Fangen wir mit B1 an.

  • Markieren Sie B1 und wählen Sie “Daten | Datenüberprüfung”
  • Wählen Sie bei “Zulassen: Liste”
  • Klicken Sie in “Quelle” und markieren Sie auf dem Blatt “Raten den Bereich A2 bis A4. Bestätigen Sie mit OK.

30.03.2016_ 0005

Weiter geht es mit A2 – markieren Sie A2 und wählen Sie wieder “Daten | Datenüberprüfung: Liste”. Die Quelle ist jetzt =Raten!$B$1:$F$1. Ebenfalls mit OK bestätigen.

In B2 kommt jetzt die Berechnung – es muss der Schnittpunkt zwischen dem Begriff aus B1 und A2 ermittelt werden. Dazu werden die Funktionen INDEX und VERGLEICH kombiniert.

=INDEX(Matrix;Zeile;Spalte)

Die Matrix ist der Bereich A1 bis F4 auf dem Blatt “Raten”. Die Zeile entspricht dem Begriff aus B1 und die Spalte dem Begriff aus A2. Um die Zeilen- bzw. Spaltennummer zu ermitteln, wird VERGLEICH verwendet.

=VERGLEICH(Suchkriterium;Suchmatrix;Vergleichstyp)

Der Vergleichstyp “0” bedeutet, dass eine genaue Übereinstimmung gesucht wird. Zuerst die Suche nach der Zeilennummer:

=VERGLEICH(B1;Raten!A1:A4;0)

Dann die Suche nach der Spaltennummer:

=VERGLEICH(A2;Raten!A1:F1;0)

Beide werden an die entsprechenden Stellen in INDEX eingebaut:

=INDEX(Raten!A1:F4;VERGLEICH(B1;Raten!A1:A4;0);VERGLEICH(A2;Raten!A1:F1;0))

30.03.2016_ 0006

Hinweis für die Fans von formatierten Tabellen: Die Matrix auf dem Blatt “Raten” kann natürlich auch als Tabelle formatiert werden, dann sind die Funktionen VERGLEICH und INDEX dynamisch.

Hinterlasse jetzt einen Kommentar

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*