Excel – MONATSENDE

In den letzten zwei Folgen habe ich Ihnen gezeigt, wie Sie mit WOCHENTAG eine Monatsliste erstellen. Es gibt noch mehr Funktionen, die Sie bei der Erstellung von Datumslisten gut verwenden können. Eine davon ist MONATSENDE.

=MONATSENDE(Datum;Anzahl Monate)

In A1 steht der 01.01.2016, Sie brauchen den letzten dieses Monats
=MONATSENDE(A1;0) ergibt 31.01.2016

Da es das Monatsende für diesen Monat sein soll, werden Null Monate dazugezählt. Jetzt kann ich eine Datumsliste ausgehend vom Ersten eines Monats erzeugen und nach unten ausfüllen, ohne selber auf den Monatsletzten achten zu müssen. Das Startdatum steht in A1:

=WENN(A1+1>MONATSENDE($A$1;0);””;A1+1)

Unschön ist nur, dass nach dem Monatsletzten eine leere Zelle kommt und dann mit der Fehlermeldung #WERT weitergemacht wird. Das liegt daran, dass immer mit der Zelle davor gerechnet wird:

06.01.2016_ 0000

Auch dieser Fehler kann vermieden werden. Das sicherste ist, immer mit A1 zu rechnen. Dann muss zuerst =A1+1, dann =A1+2, dann =A1+3 gerechnet werden – also immer eins weniger als die Zeilenzahl ist.

Die Formel lautet also:

=WENN($A$1+ZEILE()-1>MONATSENDE($A$1;0);””;$A$1+ZEILE()-1)

06.01.2016_ 0001

Dabei wird A1 absolut gesetzt ($A$1) und es wird die Zeilenzahl der aktiven Zelle abzüglich 1 addiert (+ZEILE()-1).

Diese Formel kann jetzt nach unten ausgezogen werden, ohne dass es Fehlerwerte gibt. Sie können also bis zur Zeile 32 ziehen – kein Monat hat mehr als 31 Tage – und erhalten für die kürzeren Monate einfach keine Werte.

Hinterlasse jetzt einen Kommentar

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*