Excel – Anzahl bis hierher

Es soll gezählt werden, wie oft ein Firmenname in einer Liste vorkommt. Dabei soll neben dem Firmennamen jeweils die Anzahl bis zu dieser Zeile stehen. Sortiert soll das später so aussehen:

26.11.2015_ 0001

In Zeile 2 steht “Maier & Co” das erste Mal, in Zeile 4 taucht die Firma das zweite Mal auf, in Zeile 13 zum dritten und in Zeile 15 zum vierten Mal.

Die Formel in Zelle A2 lautet:

=ZÄHLENWENN($B$2:B2;B2)

Das erste Argument gibt den Suchbereich an; das zweite den zu suchenden Begriff. Fangen wir mit dem letzten Argument an, weil das einfacher ist. Zuerst wird nach dem Begriff gesucht, der in B2 steht, eine Zeile tiefer nach dem  Begriff aus B3 und so fort. B2 wird also relativ angegeben. Beim Ausfüllen nach unten passt sich dieses Argument immer an.

Der Suchbereich für die Zählung soll immer nur bis zu der Zeile reichen, in der die aktuelle Formel steht. In der ersten Berechnung soll also nur in einer Zelle gezählt werden: in B2. Die nächste Berechnung zählt von B2 bis B3, dann von B2 bis B4, von B2 bis B5 und zum Schluss von B2 bis B18. Daraus folgt, dass der Startpunkt des Zählens immer B2 und der Endpunkt flexibel ist. Diese Anforderung “zähle bis hierher” erreicht man, indem man den Startpunkt B2 absolut setzt und den Endpunkt flexibel lässt:

=ZÄHLENWENN($B$2:B2;B2)

Beim Runterziehen wird daraus:

26.11.2015_ 0002

Sie sehen, wie sich der Bereich von B2 ausgehend immer weiter nach unten ausdehnt, bis schließlich B18 erreicht wird.

Hinterlasse jetzt einen Kommentar

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*