Office – Objekt einfügen 1

Ich werde Ihnen an drei Beispielen zeigen, wie man mit Objekten umgeht. Am Anfang steht eine Excel-Tabelle in einer Word-Vorlage.

 

04.11.2015_ 0004

 

Adresse, Datum und Rechnungs-Nummer sind Schnellbausteine. Ich verwende eine Excel-Tabelle, die als Tabelle formatiert ist und mit Formeln versehen ist. Die Summe in Zeile 4 ist die Ergebniszeile in der formatierten Tabelle (Tabellentools Entwurf | Ergebniszeile). In Zeile 5 und 6 sind die Berechnungen außerhalb der formatierten Zelle.

Es reicht aus, eine Zeile vorzugeben; ich habe zwei Zeilen, weil es so wenig Rechnung mit nur einer Position gibt. Excel füllt die Formeln automatisch weiter aus, wenn neue Zeilen entstehen.

 

04.11.2015_ 0002

Die Formeln:

A2 =ZEILE()-1
E2 =C2*D2 oder =[@Menge]*[@Einzelpreis]
E4 =SUMME(E2:E3) oder =TEILERGEBNIS(109;[Gesamt])
E5 =E4*19% oder =Tabelle1[[#Ergebnisse];[Gesamt]]*19%
E6 =E4+E5

 

Blenden Sie mit “Ansicht | Gitternetzlinien” die Linien aus und deaktivieren Sie mit “Start | Sortieren und Filtern” den AutoFilter. Speichern Sie die Tabelle.

Gestalten Sie jetzt das Worddokument mit Briefkopf, Anschriftenfeld, Datum, Betreff und so fort.

  • Wählen Sie “Einfügen | Objekt”
  • Klicken Sie auf den Reiter “Aus Datei erstellen”
  • Suchen Sie nach der Datei und bestätigen Sie mit OK

 

04.11.2015_ 0000

 

Ich verknüpfe meine Excel-Tabelle nicht, sie ist klein genug, um sie innerhalb der Worddatei zu aktualisieren.

Um die Rechnungsvorlage zu verwenden, wird sie im Explorer doppelt angeklickt oder mit “Datei | Neu | Meine Vorlagen” verwendet. Die Excel-Tabelle öffnen Sie mit einem Doppelklick. Da alles bereits mit Formeln vorgesehen ist, muss ich nur noch die Bezeichnung, die Menge und den Einzelpreis ausfüllen. In der letzten Zelle der letzten Position (bei zwei Zeilen in meinem Beispiel ist das E3) drücken Sie die Tabulator-Taste. Es wird eine neue Zeile erzeugt, die Formeln werden ausgefüllt, die Ergebnisse eine Zeile tiefer gesetzt.

Falls mehr Positionen erzeugt werden, muss vor Verlassen des Excel-Fensters das Fenster nach unten größer gezogen werden. Das Excel-Fenster passt seine Größe nicht an die tatsächlich benutzten Zeilen und Spalten an.

04.11.2015_ 0003

Achtung! Ziehen Sie keinesfalls an einem der Ränder, wenn Sie das Fenster bereits verlassen  haben! Dann verzerren Sie die Darstellung.

Um die Daten zu speichern, verlassen Sie das Excel-Fenster durch Klick in das Worddokument.

Hinterlasse jetzt einen Kommentar

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*