Excel – Die Falle schnappt zu!

Meine Falle hat gar nichts mit SVERWEIS zu tun – aber in meinem Beispiel schnappt sie beim SVERWEIS zu. Sie kann auch in Kombination mit anderen Berechnungen die Ursache von Ärger sein.
Folgende Berechnung wurde durchgeführt:

  • In Spalte A werden die Punkte für eine Klausur eingetragen.
  • In Spalte B werden die Prozente errechnet mit der Formel =A2/$F$1*100
    In F1 steht die maximal zu erreichende Punktzahl, hier 90.
  • Daraus wird über den SVERWEIS die Note in Spalte C ermittelt
    =SVERWEIS(B2;$G$2:$I$12;3;WAHR)

Hinweis: In der Matrix habe ich in der Spalte H zur Deutlichkeit den Wert “Pkte bis” eingetragen – diese Spalte ist zur Berechnung nicht notwendig und fließt in keine Berechnung kein. Ich möchte nur sehr klar zeigen, welche Punktestaffelung zugrunde liegt.

31.01.2014_ 0002

In einem Fall kommt es jetzt zu einem Fehler. Für 66,7 Prozente müsste laut Verweistabelle eine Note von 3,0 ermittelt werden – Excel gibt aber 3,3 aus. Diese Note gilt aber nur von 62,5 bis 66,6 Prozent.
Die Verweistabelle ist korrekt aufgebaut, die Punkte in Spalte G sind aufsteigend sortiert. Die Formeln sind alle korrekt. Alle anderen Ergebnisse sind ebenfalls richtig.

Wo also liegt der Fehler?

Schauen Sie sich Spalte B genauer an – alle Ergebnisse haben eine Nachkommastelle. Kann das sein? Wie viele Nachkommastellen sind zu erwarten, wenn ich rechne 62/90*100?

62/90 ergibt 0,68888889, multipliziert mit 100 kommt also 68,8888… heraus.
Kurz gesagt: Eine Menge Nachkommastellen …

Da das unerwünscht ist, wurde in der Tabelle mit dem Befehl “Dezimalstellen löschen” auf eine Nachkommastelle reduziert. Und hier lauert die Falle auf Sie: Die errechneten Dezimalstellen verwendet Excel nach wie vor, danach sucht Excel jetzt in der Verweistabelle. Das sieht so aus:

31.01.2014_ 0003

Bei 60 erreichten Punkten lautet das Ergebnis in Spalte B 66,6666666… und damit liegt der Prüfling im Bereich von 62,5 bis 66,6 und kriegt die Note 3,3.

Blende ich die Dezimalstellen aus, wird aufgerundet – aus 66,666666… wird optisch 66,7, aber eben nur optisch. Excel nimmt nach wie vor den Rattenschwanz 66,6666666…

Was also tun? Richtig runden. Und das geht so:

  • Bisher steht in B diese Formel: =A2/$F$1*100
  • Schreiben Sie stattdessen: =RUNDEN(A2/$F$1*100;1)

Jetzt wird mathematisch gerundet und Excel “sieht” auch nichts anderes – der Rattenschwanz ist verschwunden, das sind nur noch Nullen. Jetzt dürfen Sie ohne Sorge die Dezimalstellen bis auf eine löschen!

31.01.2014_ 0004

Falle

Fazit

Optisches Runden durch das Löschen von Dezimalstellen ist gefährlich, wenn Sie mit dem Ergebnis weiterrechnen!

Es gibt dazu auch noch mehr Probleme, wenn Ihnen das hier nicht reicht!

Andreas Thehos und Andreas Entenmann haben sich der “Gleitkomma-Problematik” angenommen: Video von Andreas Thehos

Ganz mathematisch im ScienceBlog von Marcus Frenkel.

 

Hinterlasse jetzt einen Kommentar

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*