Excel – Teilergebnis

Die Funktion TEILERGEBNIS dient dazu, nur Elemente zu berechnen, die sichtbar sind. Bei einer formatierten Tabelle wird automatisch die Funktion TEILERGEBNIS verwendet, wenn Sie eine Ergebniszeile hinzufügen. Sie können die Funktion aber auch in allen anderen Tabellen verwenden. Mit TEILERGEBNIS können Sie addieren, zählen, den Durchschnitt berechnen und vieles mehr. Gesteuert wird das mit Kennziffern für Funktionen.

=TEILERGEBNIS(Funktion;Bezug)

16.06.2015_ 0001

Sie sehen im Bild oben bereits, dass die Funktionen offensichtlich doppelt vorkommen: 1 Mittelwert und 101 Mittelwert. Das geht für alle weiteren Funktionen genauso: 2 Anzahl – 102 Anzahl oder 9 Summe – 109 Summe.

Was ist der Unterschied? Zuerst einmal der Unterschied zwischen =SUMME() und =TEILERGEBNIS(9;…).

SUMME(C2:C17) TEILERGEBNIS(9;C2:C17)
16.06.2015_ 0005 16.06.2015_ 0004

SUMME addiert alle Zellen: ob sichtbar oder unsichtbar, ist dabei egal. Was da ist, wird addiert.

TEILERGEBNIS(9;…) addiert die Zellen, die wir sehen. Was wir nicht sehen, wird nicht addiert. Nur stimmt das so gar nicht.

Die gleiche Tabelle mit der Funktion =TEILERGEBNIS(9;C2:C17) in C18:

16.06.2015_ 0006

Das stimmt eindeutig nicht. Achten Sie auf die Filterpfeile in diesem Bild und im Bild in der Tabelle oben rechts. Oben rechts habe ich in Spalte B nach den Kürzeln BW, BY, HE, RP gefiltert – Sie können in B1 den “Trichter” für eine aktive Filterung sehen. Im Bild oberhalb habe ich offensichtlich nicht gefiltert – alle Filterpfeile sind Pfeile, nirgendwo ein Trichter. Hier habe ich die Zellen ausgeblendet – markieren, rechte Maustaste und “Ausblenden”.

Wir müssen also ergänzen:

TEILERGEBNIS(9;…) addiert die Zellen, die bei einem AutoFilter sichtbar bleiben. Ausgeblendete Zellen hingegen werden addiert.

Und hier greift TEILERGEBNIS(109;…). Nochmal die Tabelle von oben mit =TEILERGEBNIS(109;C2:C17) in C18:

16.06.2015_ 0007

TEILERGEBNIS(109;…) addiert tatsächlich nur die Zellen, die wir sehen. Egal, ob Filter oder Ausblenden: war wir nicht sehen, wird auch nicht berechnet..

Bei formatierten Tabellen wird in der Ergebniszelle grundsätzlich die Kennziffer mit 1 davor verwendet: 101, 102, 103 etc.

1 Trackback / Pingback

  1. Excel–Unerwartetes Teilergebnis – Pia Bork

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*