Excel – SVERWEIS

Der SVERWEIS benötigt immer die Angabe, welche Spalte zurückgeliefert werden soll – und das macht ihn so unpraktisch.

Als Beispiel sollen Preise für vier verschiedene Kategorie von Ferienwohnungen herausgesucht werden:

14.06.2015_ 0000

Je nach Saison und Typ erhalte ich so andere Preise. Bei einem normalen SVERWEIS habe ich jetzt aber ein Problem: die Spalte ändert sich jedes Mal mit dem Typ. Wenn ich eine Spalte vorgebe (hier 2), kann ich immer nur den Preis für Typ I ermitteln.

=SVERWEIS(B1;$D$1:$H$4;2;FALSCH)

Um flexibel zu sein, muss ich die Spaltenzahl aus der Überschrift ermitteln. Mein Typ für die Ferienwohnung in B2 muss identisch wie die Spaltenbenennung in Zeile 1 sein. Das erreiche mit einer Datenüberprüfung vom Typ “Liste”. Die Quelle für die Liste ist E1 bis H1.

14.06.2015_ 0002

Jetzt kann ich nach dieser Bezeichnung in der Zeile 1 der Referenztabelle suchen. Dazu verwende ich die Funktion VERGLEICH. Für sich alleine gibt sie die Spaltenzahl aus:

=VERGLEICH(B2;D1:H1;0)

B2 – Suchkriterium, der Typ der Ferienwohnung
D1:H1 – Suchmatrix, die Überschrift
0 – eine genaue Übereinstimmung wird gesucht

Das Ergebnis für Typ I ist “2” – die zweite  Spalte. Und damit kann ich den SVERWEIS flexibel halten:

=SVERWEIS(B1;$D$1:$H$4;VERGLEICH(B2;D1:H1;0);FALSCH)

Je nach eingetragenem Typ erhalte ich jetzt die Spalte, in der diese Überschrift steht.

1 Trackback / Pingback

  1. 29 empfehlenswerte Artikel zu SVERWEIS / VLOOKUP – clevercalcul

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*