Excel – Heute wiederholen

In einer sehr breiten Anwesenheitsliste mit unübersichtlich vielen Spalten will der Anwender die Anwesenheiten für das aktuelle Tagesdatum immer vorne haben.

22.10.2014_ 0002

Bedingungen:

  • Es darf nichts von Hand kopiert werden
  • Das aktuelle Datum muss automatisch in B2 erscheinen
  • Die Anwesenheits-“x” müssen automatisch übertragen werden

In B2 steht =HEUTE(), damit wird immer das aktuelle Tagesdatum eingetragen.

In B3 steht die Formel:
=INDEX($C$2:$Y$7;ZEILE()-1;VERGLEICH($B$2;$C$2:$Y$2;0))

Schritt für Schritt:

Die außenliegende Funktion ist INDEX, damit werden Koordination angegeben: zur wievielten Spalte und wievielten Zeile muss ich gehen, um das erste “x” unter dem 22.10. zu bekommen?

=INDEX(Matrix;Zeile;Spalte)

Für INDEX muss zuerst ein Bereich angegeben werden – wir durchsuchen C2 bis Y7 – das ist mein Bereich oder meine Matrix.

Matrix =INDEX($C$2:$Y$7; Durchsuche den Bereich von C2 bis Y7 (absoluter Bezug, damit ich die Formel nach unten kopieren kann)

Zeile ZEILE()-1; Die Zeile ist identisch mit der Zeile der aktuellen Zelle minus 1 (für die Überschrift)

Spalte VERGLEICH Hier kommt eine weitere Funktion ins Spiel: VERGLEICH – sie liefert die Zahl der Spalte, in der das heutige Datum in der zweiten Zeile gefunden wird.
   Suchkriterium       (B$2; Suche nach dem Wert aus B2 (Heute)
   Matrix        $C$2:$Y$2; Suche im Bereich von C2 bis Y2 (Achtung! Nur in der Überschriftszeile suchen!)
   Typ        0) Suche eine genaue Übereinstimmung (0)

Wenn man VERGLEICH für sich alleine verwendet, liefert es eine Nummer:

=VERGLEICH(B2;C2:W2;0)

liefert für das Tagesdatum 22.10.2014 in meinem Beispiel die Zahl “16” zurück. Das bedeutet, dass in der Spalte 16 beginnend bei C2 das Suchkriterium gefunden wurde.

Aus ZEILE()-1 und dem gesamten VERGLEICH ergeben sich die Koordinaten:

  • VERGLEICH liefert die Spaltennummer
    Für das Datum 07.10.2014 wird ermittelt, dass es in der Markierung von C2 bis Y2 in der fünften Spalte liegt.
  • ZEILE()-1 liefert als Zeilennummer für “Müller” die Zahl “2”
  • In der Matrix von C2 bis Y7 hat “Müller” heute sein Anwesenheitskennzeichen in Spalte 5 und Zeile 2.

22.10.2014_ 0003

Damit für abwesende Mitarbeiter, die kein “x” haben, nicht eine 0 eingetragen wird, sind die Zellen in Spalte B benutzerdefiniert so formatiert:

Typ: 0;0;;@

22.10.2014_ 0005

Damit wird angegeben, dass weder für positive Zahlen (erste 0) noch für negative Zahlen (zweite 0) irgendeine besondere Formatierung gilt. Dann folgen zwei Semikola aufeinander – damit werden “Null”-Werte unterdrückt. Das @-Zeichen muss nicht angegeben werden – es gibt an, dass Text standardmäßig formatiert wird.

Zusätzlich werden alle Namen, die in der Spalte B ein “x” haben, fett formatiert. Das ist eine bedingte Formatierung.

Die Regel ist vom Typ “Formel zur Ermittlung … verwenden”.

Die Formel ist

=$B3=”x”

Das Format ist nur die Schriftformatierung fett.

22.10.2014_ 0004

1 Trackback / Pingback

  1. Erinnerung: Excel VERGLEICH und INDEX | Pia Bork – Office Training München

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*