Excel – Wenn Datum

Prinzipiell funktioniert WENN auch mit einem Datum und mit Uhrzeiten …  naja, prinzipiell. Zu Uhrzeiten habe ich schon einen Eintrag im Lexikon: Wenn Uhrzeit größer als

Hier geht es um “Wenn Datum größer ist als …”.

Einfach ist diese Aufgabe:

In B1 steht ein Stichtag, von A2 bis A30 steht eine Datumsliste. In Spalte B soll der Stichtag gekennzeichnet werden.
Ändert man in B1 das Datum, soll in der Liste der korrekte Tag gekennzeichnet werden.

Die Formel lautet:

=WENN(A2=$B$1;”Stichtag”;””)

Diese Formel wird nach unten ausgefüllt.

22.10.2014_ 0000

Anders ist die Aufgabe, wenn das Datum nicht in eine Zelle geschrieben werden kann, sondern in der WENN-Formel direkt eingegeben wird: In eine Zelle wird ein Datum eingegeben und es soll geprüft werden, ob dieses Datum zwischen zwei Eckdaten liegt. Beispielsweise soll hier geprüft werden, ob das eingegebene Datum im IV. Quartal liegt – also zwischen dem 01.10.und dem 31.12.

Die WENN-Formel muss prüfen, ob das Datum in A2 größer als 01.10.2014 und kleiner als 31.12.2014 ist. 22.10.2014_ 0001

Die WENN-Funktion sieht prinzipiell so aus:

=WENN(UND(A2>erstes Datum;A2<zweites Datum);”ja”;””)

Aber eine Schreibweise wie “A2>01.10.2014” bzw. “A2<31.12.2014” führt zu einer Fehlermeldung. Und bevor Sie es probieren: auch mit Anführungszeichen um das Datum geht es nicht.

Korrekt muss es so aussehen:

=WENN(UND(A2>DATUM(2014;10;1);A2<DATUM(2014;12;31);”ja”;””)

Das Datum kann nur abgefragt werden mit dem “Aufdröseln” des Datums in Jahr, Monat und Tag. Das übernimmt die Funktion DATUM. In ihr wird das Datum in der Form JJJJ;MM;DD eingegeben.

Hinterlasse jetzt einen Kommentar

Kommentar hinterlassen

E-Mail Adresse wird nicht veröffentlicht.


*