Excel–SVERWEIS mit zwei Matrix-Möglichkeiten

Mit einem SVERWEIS sollen wahlweise die Werte aus der ersten oder zweiten Matrix ausgelesen werden:

18.01.2017_0000

Beide Typen haben die gleichen Kennziffern. Bei Typ A soll die Matrix E2:F6 gelten, bei Typ gilt die Matrix H2:I6. Die unterschiedlichen Bereiche werden mit einer WENN-Funktion ermittelt:

WENN(B2=”A”;E2:F6;H2:I6)

Diese WENN wird in den SVERWEIS an der Stelle eingebaut, an der die Matrix abgefragt wird:

SVERWEIS(Suchkriterium;Matrix;Spaltenindex;Bereich_Verweis)

Suchkriterium: A2
Spaltenindex in beiden Fällen: 2 (immer die zweite Spalte muss ausgelesen werden)
Bereich_Verweis: ist immer “genaue Übereinstimmung” – also FALSCH

=SVERWEIS(A2;WENN(B2=”A”;E2:F6;H2:I6);2;FALSCH)

Ich habe für TypA und TypB eine formatierte Tabelle verwendet und beide Tabellen auch so benannt. Dann sieht die Funktion etwas anders aus, weil keine Zellenbezüge, sondern Namen verwendet werden:

18.01.2017_0001

=SVERWEIS(A2;WENN(B2=“A“;TypA[#Alle];TypB[#Alle]);2;FALSCH)

Achten Sie darauf, dass die formatierte Tabelle erst in Zeile 2 beginnt! Zeile 1 mit “Typ A” und “Typ B” ist nicht Bestandteil der Tabelle!