Excel–Runde Geburtstage

In einer Geburtstagsliste sollen alle runden Geburtstage markiert werden. Dabei soll das Alter für das gesamte Jahr im Voraus berechnet werden – egal, in welchem Monat diesen Jahres jemand 50 wird, es soll bereits ab dem 01. Januar “50” angezeigt werden. Wenn Sie das Alter taggenau berechnen wollen, müssen Sie einen anderen Weg wählen als hier beschrieben.

Wir haben zuerst diese Tabelle erstellt: Erfasst werden Nachname und Vorname sowie das Geburtsdatum. In Spalte D errechnet sich das Alter in Jahren so:

=JAHR(HEUTE())-JAHR(C2)

31.01.2017_ 0000

In Spalte E haben wir ermittelt, ob das ein runder Geburtstag ist. Dazu verwende ich die Funktion REST(). REST gibt an, ob bei der Division etwas übrigbleibt. Erforderlich ist es, die Zahl anzugeben, die geteilt werden soll und den Divisor. Ich lasse durch 10 teilen, um die runden Geburtstage zu ermitteln: 50 / 10 = 5, ohne Rest; 49 / 10 = 4 mit Rest 9. Die Funktion in Spalte E lautet:

=WENN(REST(D2;10)=0;”rund”;””)

Also: Wenn bei der Teilung der Zahl 10 das Ergebnis Null ist, dann schreibe “rund”, sonst lasse die Zelle leer.

Das kann man natürlich auch als bedingte Formatierung auf die Spalte D legen:

  • Markieren Sie D2 bis zum Ende
  • Wählen Sie “Start | Bedingte Formatierung | Neue Regel”
  • Aktivieren Sie “Formel zur Ermittlung der zu formatierenden Zellen verwenden”

31.01.2017_0000

Tragen Sie als Formel ein =REST(D2;10)=10 und klicken Sie auf “Formatieren”, um eine Füllfarbe auszuwählen.

Achten Sie darauf, dass D2 ein relativer Bezug bleibt! Wenn Excel den Bezug zu einem absoluten umwandelt, löschen Sie die Dollarzeichen unbedingt heraus.