Quiztime – Lösung Excel Daten ausgeben

Haben Sie herausgefunden, wie man die Aufgabe vom Freitag lösen kann?

Eingetragen wird der Monat und der Ort in A2 und B2.
  • Daraus soll zuerst der Grundpreis ausgegeben werden – er ergibt sich aus dem Ort und dem Preis aus Tabelle (3).
  • Dann wird die Saison ermittelt. Sie ergibt sich aus dem Ort und dem Monat aus Tabelle (1).
  • Aus der Saison ergibt sich der Zuschlag in Prozent aus Tabelle (2).
  • Grundpreis plus Zuschlag in Prozent ergibt dann den tatsächlichen Preis pro Nacht in F2.
Grundpreis ermitteln in C2 mit einem simplen SVERWEIS:
=SVERWEIS(B2;A15:B17;2;FALSCH)
Suche nach dem Ort aus B2 (München) in der Matrix von A15 bis B17 und gib den Wert aus der zweiten Spalte.
Die Saison herausfinden in D2 mit INDEX und VERGLEICH:
=INDEX(A6:E9;VERGLEICH(B2;A6:A9;0);VERGLEICH(A2;A6:E6;0))
Suche in der Matrix von A6 bis E9. Ermittle zuerst die Zeile, indem Du den Wert aus B2 (München) im Bereich von A6 bis A9 suchst. Ermittle dann die Spalte, indem Du den Wert aus A2 (März) im Bereich von A6 bis E6 suchst. Den Schnittpunkt (München/März = B) gib als Saison aus.
Den Zuschlag in Prozent ermitteln in E2 mit einem SVERWEIS:
=SVERWEIS(D2;A11:B13;2;FALSCH)
Suche nach dem Saisonbuchstaben aus D2 (B) in der Matrix von A11 bis B13 und gib den Wert der zweiten Spalte aus (15 %).
Die tatsächlichen Kosten pro Nacht errechnen in F2:
=C2+C2*E2
Addiere zum Grundpreis aus C2 den Zuschlag in Prozent (E2).
Und alles in einer Formel?
Dann ersetzen Sie C2 jeweils durch die Formel, die in C2 steht und E2 durch die Formel aus E2. Das sieht dann so aus:
=SVERWEIS(B2;A15:B17;2;FALSCH)+SVERWEIS(B2;A15:B17;2;FALSCH)* SVERWEIS(INDEX(A6:E9;VERGLEICH(B2;A6:A9;0); VERGLEICH(A2;A6:E6;0));A11:B13;2;FALSCH)
Und hier gibt es die Tabelle mit Lösung zum Download.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.